Quantcast

What's wrong in Squirrelmail OpenSuse 13.2?

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

What's wrong in Squirrelmail OpenSuse 13.2?

regni
Hi,
We have been successfully using squirrelmail as front end to our UW IMAP
servers until a couple of days ago using the following combination:

   Squirrelmail version 1.5.2
   Apache version 2.4.6
   PHP version 5.4.20

When we upgraded the OS on our web server to OpenSuse 13.2, which implies
(in bundle from YaST2 with dependencies checked)

   Squirrelmail version 1.5.2
   Apache version 2.4.10
   PHP version 5.6.1

we are not able anymore to login. We get the following error message:

   Error connecting to IMAP server: tls://imap-ifc.0:

and in /var/log/mail of *REMOTE* IMAP server we see the following error:

   Unexpected client disconnect, while reading line user=??? host=UNKNOWN

The IMAP server (UW IMAP4rev1 2007e.404 under OpenSuse 13.2) has not
changed and is happily accepting connections (TLS/SSL ports 143/993) from
other imap clients (alpine, thunderbird, Kmail) ... and from Squirrelmail
(1.5.2 in bundle) of OpenSuse 13.1!

//////////////////////////////////////////
The problem is NOT the remote IMAP server!
\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\

With Squirrelmail these dependencies (both OpenSuse versions 13.1 and
13.2) are installed:

php-gettext
php-session
mod_php_any
php-mbstring
php-iconv
php-ctype
php-hash
php-mcrypt
php-openssl
php-posix
php-sockets
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsLzma) <= 4.4.6-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1

...other informations... debug step by step...

Apparently the login form passes correctly the arguments to routine
sqimap_login in ./functions/imap_general.php, but the error is generated
in routine sqimap_create_stream

Any ideas?

Thanks in advance
Roberto

------------------------------------------------------------------------------
Dive into the World of Parallel Programming The Go Parallel Website, sponsored
by Intel and developed in partnership with Slashdot Media, is your hub for all
things parallel software development, from weekly thought leadership blogs to
news, videos, case studies, tutorials and more. Take a look and join the
conversation now. http://goparallel.sourceforge.net/
-----
squirrelmail-users mailing list
Posting guidelines: http://squirrelmail.org/postingguidelines
List address: [hidden email]
List archives: http://news.gmane.org/gmane.mail.squirrelmail.user
List info (subscribe/unsubscribe/change options): https://lists.sourceforge.net/lists/listinfo/squirrelmail-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: What's wrong in Squirrelmail OpenSuse 13.2?

Paul Lesniewski
On 3/9/15, [hidden email] <[hidden email]> wrote:

> Hi,
> We have been successfully using squirrelmail as front end to our UW IMAP
> servers until a couple of days ago using the following combination:
>
>    Squirrelmail version 1.5.2
>    Apache version 2.4.6
>    PHP version 5.4.20
>
> When we upgraded the OS on our web server to OpenSuse 13.2, which implies
> (in bundle from YaST2 with dependencies checked)
>
>    Squirrelmail version 1.5.2
>    Apache version 2.4.10
>    PHP version 5.6.1
>
> we are not able anymore to login. We get the following error message:
>
>    Error connecting to IMAP server: tls://imap-ifc.0:
>
> and in /var/log/mail of *REMOTE* IMAP server we see the following error:
>
>    Unexpected client disconnect, while reading line user=??? host=UNKNOWN
>
> The IMAP server (UW IMAP4rev1 2007e.404 under OpenSuse 13.2) has not
> changed and is happily accepting connections (TLS/SSL ports 143/993) from
> other imap clients (alpine, thunderbird, Kmail) ... and from Squirrelmail
> (1.5.2 in bundle) of OpenSuse 13.1!
>
> //////////////////////////////////////////
> The problem is NOT the remote IMAP server!
> \\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\
>
> With Squirrelmail these dependencies (both OpenSuse versions 13.1 and
> 13.2) are installed:
>
> php-gettext
> php-session
> mod_php_any
> php-mbstring
> php-iconv
> php-ctype
> php-hash
> php-mcrypt
> php-openssl
> php-posix
> php-sockets
> rpmlib(CompressedFileNames) <= 3.0.4-1
> rpmlib(PayloadFilesHavePrefix) <= 4.0-1
> rpmlib(PayloadIsLzma) <= 4.4.6-1
> rpmlib(PartialHardlinkSets) <= 4.0.4-1
>
> ...other informations... debug step by step...
>
> Apparently the login form passes correctly the arguments to routine
> sqimap_login in ./functions/imap_general.php, but the error is generated
> in routine sqimap_create_stream
>
> Any ideas?

We have no knowledge of what OpenSuse changed between releases in
their re-packaged version of SquirrelMail.  This is a question for
them.

--
Paul Lesniewski
SquirrelMail Team
Please support Open Source Software by donating to SquirrelMail!
http://squirrelmail.org/donate_paul_lesniewski.php

------------------------------------------------------------------------------
Dive into the World of Parallel Programming The Go Parallel Website, sponsored
by Intel and developed in partnership with Slashdot Media, is your hub for all
things parallel software development, from weekly thought leadership blogs to
news, videos, case studies, tutorials and more. Take a look and join the
conversation now. http://goparallel.sourceforge.net/
-----
squirrelmail-users mailing list
Posting guidelines: http://squirrelmail.org/postingguidelines
List address: [hidden email]
List archives: http://news.gmane.org/gmane.mail.squirrelmail.user
List info (subscribe/unsubscribe/change options): https://lists.sourceforge.net/lists/listinfo/squirrelmail-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: What's wrong in Squirrelmail OpenSuse 13.2?

regni
In reply to this post by regni
On Wed, 11 Mar 2015, Paul Lesniewski wrote:

> On 3/9/15, [hidden email] <[hidden email]> wrote:
>> Hi,
>> We have been successfully using squirrelmail as front end to our UW IMAP
>> servers until a couple of days ago using the following combination:
>>
>>    Squirrelmail version 1.5.2
>>    Apache version 2.4.6
>>    PHP version 5.4.20
>>
>> When we upgraded the OS on our web server to OpenSuse 13.2, which implies
>> (in bundle from YaST2 with dependencies checked)
>>
>>    Squirrelmail version 1.5.2
>>    Apache version 2.4.10
>>    PHP version 5.6.1
>>
>> we are not able anymore to login. We get the following error message:
>>
>>    Error connecting to IMAP server: tls://imap-ifc.0:
>>
>> and in /var/log/mail of *REMOTE* IMAP server we see the following error:
>>
>>    Unexpected client disconnect, while reading line user=??? host=UNKNOWN
>>
>> The IMAP server (UW IMAP4rev1 2007e.404 under OpenSuse 13.2) has not
>> changed and is happily accepting connections (TLS/SSL ports 143/993) from
>> other imap clients (alpine, thunderbird, Kmail) ... and from Squirrelmail
>> (1.5.2 in bundle) of OpenSuse 13.1!
>>
>> //////////////////////////////////////////
>> The problem is NOT the remote IMAP server!
>> \\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\
>>
>> With Squirrelmail these dependencies (both OpenSuse versions 13.1 and
>> 13.2) are installed:
>>
>> php-gettext
>> php-session
>> mod_php_any
>> php-mbstring
>> php-iconv
>> php-ctype
>> php-hash
>> php-mcrypt
>> php-openssl
>> php-posix
>> php-sockets
>> rpmlib(CompressedFileNames) <= 3.0.4-1
>> rpmlib(PayloadFilesHavePrefix) <= 4.0-1
>> rpmlib(PayloadIsLzma) <= 4.4.6-1
>> rpmlib(PartialHardlinkSets) <= 4.0.4-1
>>
>> ...other informations... debug step by step...
>>
>> Apparently the login form passes correctly the arguments to routine
>> sqimap_login in ./functions/imap_general.php, but the error is generated
>> in routine sqimap_create_stream
>>
>> Any ideas?
>
> We have no knowledge of what OpenSuse changed between releases in
> their re-packaged version of SquirrelMail.  This is a question for
> them.
>
True, but from 'squirremail.org' I had installed both version SquirreMail
(1.4.22 stable and 1.5.2 SVN) on TWO PC with OpenSuse 13.2 and I had the same
problem:
"Error connecting to IMAP server: tls://imap-ifc.0:"

Module or library missing? Is't possible? But which one?

Roberto

------------------------------------------------------------------------------
Dive into the World of Parallel Programming The Go Parallel Website, sponsored
by Intel and developed in partnership with Slashdot Media, is your hub for all
things parallel software development, from weekly thought leadership blogs to
news, videos, case studies, tutorials and more. Take a look and join the
conversation now. http://goparallel.sourceforge.net/
-----
squirrelmail-users mailing list
Posting guidelines: http://squirrelmail.org/postingguidelines
List address: [hidden email]
List archives: http://news.gmane.org/gmane.mail.squirrelmail.user
List info (subscribe/unsubscribe/change options): https://lists.sourceforge.net/lists/listinfo/squirrelmail-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: What's wrong in Squirrelmail OpenSuse 13.2?

Niclas Arndt
Roberto,

I sent you a private e-mail yesterday advicing you to check the forum history from 2014-12 until now. You should always search for a solution first (without being instructed to do so), so the people on the forums only have to spend time on solving a problem once.

I have posted detailed information about which versions work on OpenSUSE 13.2 and what version-change-related issues I had to address. Go read it.

/Niclas


> Date: Wed, 11 Mar 2015 11:06:55 +0100
> From: [hidden email]
> To: [hidden email]
> Subject: Re: [SM-USERS] What's wrong in Squirrelmail OpenSuse 13.2?
>
> On Wed, 11 Mar 2015, Paul Lesniewski wrote:
>
> > On 3/9/15, [hidden email] <[hidden email]> wrote:
> >> Hi,
> >> We have been successfully using squirrelmail as front end to our UW IMAP
> >> servers until a couple of days ago using the following combination:
> >>
> >>    Squirrelmail version 1.5.2
> >>    Apache version 2.4.6
> >>    PHP version 5.4.20
> >>
> >> When we upgraded the OS on our web server to OpenSuse 13.2, which implies
> >> (in bundle from YaST2 with dependencies checked)
> >>
> >>    Squirrelmail version 1.5.2
> >>    Apache version 2.4.10
> >>    PHP version 5.6.1
> >>
> >> we are not able anymore to login. We get the following error message:
> >>
> >>    Error connecting to IMAP server: tls://imap-ifc.0:
> >>
> >> and in /var/log/mail of *REMOTE* IMAP server we see the following error:
> >>
> >>    Unexpected client disconnect, while reading line user=??? host=UNKNOWN
> >>
> >> The IMAP server (UW IMAP4rev1 2007e.404 under OpenSuse 13.2) has not
> >> changed and is happily accepting connections (TLS/SSL ports 143/993) from
> >> other imap clients (alpine, thunderbird, Kmail) ... and from Squirrelmail
> >> (1.5.2 in bundle) of OpenSuse 13.1!
> >>
> >> //////////////////////////////////////////
> >> The problem is NOT the remote IMAP server!
> >> \\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\
> >>
> >> With Squirrelmail these dependencies (both OpenSuse versions 13.1 and
> >> 13.2) are installed:
> >>
> >> php-gettext
> >> php-session
> >> mod_php_any
> >> php-mbstring
> >> php-iconv
> >> php-ctype
> >> php-hash
> >> php-mcrypt
> >> php-openssl
> >> php-posix
> >> php-sockets
> >> rpmlib(CompressedFileNames) <= 3.0.4-1
> >> rpmlib(PayloadFilesHavePrefix) <= 4.0-1
> >> rpmlib(PayloadIsLzma) <= 4.4.6-1
> >> rpmlib(PartialHardlinkSets) <= 4.0.4-1
> >>
> >> ...other informations... debug step by step...
> >>
> >> Apparently the login form passes correctly the arguments to routine
> >> sqimap_login in ./functions/imap_general.php, but the error is generated
> >> in routine sqimap_create_stream
> >>
> >> Any ideas?
> >
> > We have no knowledge of what OpenSuse changed between releases in
> > their re-packaged version of SquirrelMail.  This is a question for
> > them.
> >
> True, but from 'squirremail.org' I had installed both version SquirreMail
> (1.4.22 stable and 1.5.2 SVN) on TWO PC with OpenSuse 13.2 and I had the same
> problem:
> "Error connecting to IMAP server: tls://imap-ifc.0:"
>
> Module or library missing? Is't possible? But which one?
>
> Roberto
>
> ------------------------------------------------------------------------------
> Dive into the World of Parallel Programming The Go Parallel Website, sponsored
> by Intel and developed in partnership with Slashdot Media, is your hub for all
> things parallel software development, from weekly thought leadership blogs to
> news, videos, case studies, tutorials and more. Take a look and join the
> conversation now. http://goparallel.sourceforge.net/
> -----
> squirrelmail-users mailing list
> Posting guidelines: http://squirrelmail.org/postingguidelines
> List address: [hidden email]
> List archives: http://news.gmane.org/gmane.mail.squirrelmail.user
> List info (subscribe/unsubscribe/change options): https://lists.sourceforge.net/lists/listinfo/squirrelmail-users
     
------------------------------------------------------------------------------
Dive into the World of Parallel Programming The Go Parallel Website, sponsored
by Intel and developed in partnership with Slashdot Media, is your hub for all
things parallel software development, from weekly thought leadership blogs to
news, videos, case studies, tutorials and more. Take a look and join the
conversation now. http://goparallel.sourceforge.net/
-----
squirrelmail-users mailing list
Posting guidelines: http://squirrelmail.org/postingguidelines
List address: [hidden email]
List archives: http://news.gmane.org/gmane.mail.squirrelmail.user
List info (subscribe/unsubscribe/change options): https://lists.sourceforge.net/lists/listinfo/squirrelmail-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: What's wrong in Squirrelmail OpenSuse 13.2?

Paul Lesniewski
Please do not top-post.

>> >> We have been successfully using squirrelmail as front end to our UW
>> >> IMAP
>> >> servers until a couple of days ago using the following combination:
>> >>
>> >>    Squirrelmail version 1.5.2
>> >>    Apache version 2.4.6
>> >>    PHP version 5.4.20
>> >>
>> >> When we upgraded the OS on our web server to OpenSuse 13.2, which
>> >> implies
>> >> (in bundle from YaST2 with dependencies checked)
>> >>
>> >>    Squirrelmail version 1.5.2
>> >>    Apache version 2.4.10
>> >>    PHP version 5.6.1
>> >>
>> >> we are not able anymore to login. We get the following error message:
>> >>
>> >>    Error connecting to IMAP server: tls://imap-ifc.0:
>> >>
>> >> and in /var/log/mail of *REMOTE* IMAP server we see the following
>> >> error:
>> >>
>> >>    Unexpected client disconnect, while reading line user=???
>> >> host=UNKNOWN
>> >>
>> >> The IMAP server (UW IMAP4rev1 2007e.404 under OpenSuse 13.2) has not
>> >> changed and is happily accepting connections (TLS/SSL ports 143/993)
>> >> from
>> >> other imap clients (alpine, thunderbird, Kmail) ... and from
>> >> Squirrelmail
>> >> (1.5.2 in bundle) of OpenSuse 13.1!
>> >>
>> >> //////////////////////////////////////////
>> >> The problem is NOT the remote IMAP server!
>> >> \\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\
>> >>
>> >> With Squirrelmail these dependencies (both OpenSuse versions 13.1 and
>> >> 13.2) are installed:
>> >>
>> >> php-gettext
>> >> php-session
>> >> mod_php_any
>> >> php-mbstring
>> >> php-iconv
>> >> php-ctype
>> >> php-hash
>> >> php-mcrypt
>> >> php-openssl
>> >> php-posix
>> >> php-sockets
>> >> rpmlib(CompressedFileNames) <= 3.0.4-1
>> >> rpmlib(PayloadFilesHavePrefix) <= 4.0-1
>> >> rpmlib(PayloadIsLzma) <= 4.4.6-1
>> >> rpmlib(PartialHardlinkSets) <= 4.0.4-1
>> >>
>> >> ...other informations... debug step by step...
>> >>
>> >> Apparently the login form passes correctly the arguments to routine
>> >> sqimap_login in ./functions/imap_general.php, but the error is
>> >> generated
>> >> in routine sqimap_create_stream
>> >>
>> >> Any ideas?
>> >
>> > We have no knowledge of what OpenSuse changed between releases in
>> > their re-packaged version of SquirrelMail.  This is a question for
>> > them.
>> >
>> True, but from 'squirremail.org' I had installed both version SquirreMail
>>
>> (1.4.22 stable and 1.5.2 SVN) on TWO PC with OpenSuse 13.2 and I had the
>> same
>> problem:
>> "Error connecting to IMAP server: tls://imap-ifc.0:"
>>
>> Module or library missing? Is't possible? But which one?
>
> I sent you a private e-mail yesterday advicing you to check the forum
> history from 2014-12 until now. You should always search for a solution
> first (without being instructed to do so), so the people on the forums only
> have to spend time on solving a problem once.
>
> I have posted detailed information about which versions work on OpenSUSE
> 13.2 and what version-change-related issues I had to address. Go read it.

I don't see anything in your previous thread about TLS issues.  This
issue looks similar to this one:

http://thread.gmane.org/gmane.mail.squirrelmail.user/39790

It'd be good if someone seeing this issue could first confirm if it
happens with code downloaded from squirrelmail.org and *NOT* a vendor
re-package.  And then if it does, it would be helpful if you could
show your configuration and do some debugging for us.

--
Paul Lesniewski
SquirrelMail Team
Please support Open Source Software by donating to SquirrelMail!
http://squirrelmail.org/donate_paul_lesniewski.php

------------------------------------------------------------------------------
Dive into the World of Parallel Programming The Go Parallel Website, sponsored
by Intel and developed in partnership with Slashdot Media, is your hub for all
things parallel software development, from weekly thought leadership blogs to
news, videos, case studies, tutorials and more. Take a look and join the
conversation now. http://goparallel.sourceforge.net/
-----
squirrelmail-users mailing list
Posting guidelines: http://squirrelmail.org/postingguidelines
List address: [hidden email]
List archives: http://news.gmane.org/gmane.mail.squirrelmail.user
List info (subscribe/unsubscribe/change options): https://lists.sourceforge.net/lists/listinfo/squirrelmail-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: What's wrong in Squirrelmail OpenSuse 13.2?

David C. Rankin
On 03/11/2015 05:43 AM, Paul Lesniewski wrote:
> I don't see anything in your previous thread about TLS issues.  This
> issue looks similar to this one:
>
> http://thread.gmane.org/gmane.mail.squirrelmail.user/39790
>
> It'd be good if someone seeing this issue could first confirm if it
> happens with code downloaded from squirrelmail.org and*NOT*  a vendor
> re-package.  And then if it does, it would be helpful if you could
> show your configuration and do some debugging for us.

Paul,

   I have just updated to 1.5.2 svn rev 14501 and I am experiencing this exact
issue I believe. I have sent a detailed write-up of the upgrade and login
failure to the list under Subject:

svn 14501 - TLS handshaking: SSL_accept() failed: error: ... alert unknown ca:
SSL alert number 48

   I am just dropping a note here to let you know I have a pure squirrelmail.org
install and it is response to your request here. We'll work it under the other
thread.

--
David C. Rankin, J.D.,P.E.

------------------------------------------------------------------------------
-----
squirrelmail-users mailing list
Posting guidelines: http://squirrelmail.org/postingguidelines
List address: [hidden email]
List archives: http://news.gmane.org/gmane.mail.squirrelmail.user
List info (subscribe/unsubscribe/change options): https://lists.sourceforge.net/lists/listinfo/squirrelmail-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: What's wrong in Squirrelmail OpenSuse 13.2?

Paul Lesniewski
On 6/12/15, David C. Rankin <[hidden email]> wrote:

> On 03/11/2015 05:43 AM, Paul Lesniewski wrote:
>> I don't see anything in your previous thread about TLS issues.  This
>> issue looks similar to this one:
>>
>> http://thread.gmane.org/gmane.mail.squirrelmail.user/39790
>>
>> It'd be good if someone seeing this issue could first confirm if it
>> happens with code downloaded from squirrelmail.org and*NOT*  a vendor
>> re-package.  And then if it does, it would be helpful if you could
>> show your configuration and do some debugging for us.
>
> Paul,
>
>    I have just updated to 1.5.2 svn rev 14501 and I am experiencing this
> exact
> issue I believe. I have sent a detailed write-up of the upgrade and login
> failure to the list under Subject:
>
> svn 14501 - TLS handshaking: SSL_accept() failed: error: ... alert unknown
> ca:
> SSL alert number 48
>
>    I am just dropping a note here to let you know I have a pure
> squirrelmail.org
> install and it is response to your request here. We'll work it under the
> other
> thread.

For the benefit of the archives, I suspect the problem here is that
you need to fine tune the SSL context.  You can do so by specifying
$imap_stream_options in config/config_local.php.  The documentation
for this setting can be found in the example config_local for 1.5.2
here:

http://sourceforge.net/p/squirrelmail/code/HEAD/tree/trunk/squirrelmail/config/config_local.example.php

The setting should do the same thing in 1.4.23.  Also note there is a
setting there for the SMTP side as well.

--
Paul Lesniewski
SquirrelMail Team
Please support Open Source Software by donating to SquirrelMail!
http://squirrelmail.org/donate_paul_lesniewski.php

------------------------------------------------------------------------------
-----
squirrelmail-users mailing list
Posting guidelines: http://squirrelmail.org/postingguidelines
List address: [hidden email]
List archives: http://news.gmane.org/gmane.mail.squirrelmail.user
List info (subscribe/unsubscribe/change options): https://lists.sourceforge.net/lists/listinfo/squirrelmail-users
Loading...