[SM-USERS] Fwd: Bug Report

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[SM-USERS] Fwd: Bug Report

Jamie Townsend-2
I subscribe to the squirrelmail-users mailing list.
  [ ]  True - No need to CC me when replying
  [x]  False - Please CC me when replying

This bug occurs when I ...

  - Move an email to a folder.


The description of the bug:

    After reading an email and using the 'File' Select box to move a the
message to another folder, I recieve the following error

    ERROR : Bad or malformed request.
    Query: FETCH -1 (FLAGS BODYSTRUCTURE)
    Server responded: Bogus sequence in UID FETCH: Syntax error in sequence


I can reproduce the bug by:

    It is the greatest type of problem...intermittent. It happens from
time to time and I have not been able to tie it down to any one thing
in particular. I'll keep trying to see what scenarios seem to cause
this more than others.

(Optional) I got bored and found the bug occurs in:


(Optional) I got really bored and here's a fix:


----------------------------------------------

My browser information:
  Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

My web server information:
  PHP Version 4.3.10
  PHP Extensions (List)
    * 0 = yp
    * 1 = xml
    * 2 = wddx
    * 3 = tokenizer
    * 4 = sysvshm
    * 5 = sysvsem
    * 6 = standard
    * 7 = sockets
    * 8 = shmop
    * 9 = session
    * 10 = posix
    * 11 = pcre
    * 12 = overload
    * 13 = mhash
    * 14 = imap
    * 15 = iconv
    * 16 = gmp
    * 17 = gd
    * 18 = ftp
    * 19 = exif
    * 20 = dbase
    * 21 = dba
    * 22 = ctype
    * 23 = calendar
    * 24 = bz2
    * 25 = bcmath
    * 26 = zlib
    * 27 = openssl
    * 28 = apache
    * 29 = mysql
    * 30 = gettext

SquirrelMail-specific information:
  Version:  1.5.0
  Plugins (List)
    * 0 = newmail
    * 1 = administrator
    * 2 = compatibility
    * 3 = calendar_file_backend
    * 4 = filters
    * 5 = calendar
    * 6 = bookmarks
    * 7 = html_mail
    * 8 = address_add
    * 9 = bug_report

My IMAP server information:
  Server type:  other
  Server info:  * OK [HIDDEN] IMAP4REV1 LITERAL+ SASL-IR LOGIN-REFERRALS
STARTTLS AUTH=LOGIN] localhost IMAP4rev1 2004.356 at Mon, 7 Nov 2005
09:41:48 +1100 (EST)
  Cabailities:  IMAP4REV1 LITERAL+ IDLE NAMESPACE MAILBOX-REFERRALS BINARY
UNSELECT SCAN SORT THREAD=REFERENCES THREAD=ORDEREDSUBJECT MULTIAPPEND
SASL-IR LOGIN-REFERRALS STARTTLS AUTH=LOGIN





-------------------------------------------------------
SF.Net email is sponsored by:
Tame your development challenges with Apache's Geronimo App Server. Download
it for free - -and be entered to win a 42" plasma tv or your very own
Sony(tm)PSP.  Click here to play: http://sourceforge.net/geronimo.php
--
squirrelmail-users mailing list
Posting Guidelines: http://www.squirrelmail.org/wiki/MailingListPostingGuidelines
List Address: [hidden email]
List Archives: http://news.gmane.org/thread.php?group=gmane.mail.squirrelmail.user
List Archives:  http://sourceforge.net/mailarchive/forum.php?forum_id=2995
List Info: https://lists.sourceforge.net/lists/listinfo/squirrelmail-users
Reply | Threaded
Open this post in threaded view
|

Re: [SM-USERS] Fwd: Bug Report

Tomas Kuliavas
> I subscribe to the squirrelmail-users mailing list.
>   [ ]  True - No need to CC me when replying
>   [x]  False - Please CC me when replying
>
> This bug occurs when I ...
>
>   - Move an email to a folder.
>
>
> The description of the bug:
>
>     After reading an email and using the 'File' Select box to move a the
> message to another folder, I recieve the following error
>
>     ERROR : Bad or malformed request.
>     Query: FETCH -1 (FLAGS BODYSTRUCTURE)
>     Server responded: Bogus sequence in UID FETCH: Syntax error in
> sequence
>
>
> I can reproduce the bug by:
>
>     It is the greatest type of problem...intermittent. It happens from
> time to time and I have not been able to tie it down to any one thing
> in particular. I'll keep trying to see what scenarios seem to cause
> this more than others.
>
...
> SquirrelMail-specific information:
>   Version:  1.5.0
...
> My IMAP server information:
>   Server type:  other
>   Server info:  * OK [HIDDEN] IMAP4REV1 LITERAL+ SASL-IR LOGIN-REFERRALS
> STARTTLS AUTH=LOGIN] localhost IMAP4rev1 2004.356 at Mon, 7 Nov 2005
> 09:41:48 +1100 (EST)

SquirrelMail 1.5.0 is old development version. Please make sure that you
can reproduce error in 1.5.1cvs or 1.4.5.

Remember that you should configure your imap server correctly.
SquirrelMail has separate configuration preset for UW IMAP server.

--
Tomas


-------------------------------------------------------
SF.Net email is sponsored by:
Tame your development challenges with Apache's Geronimo App Server. Download
it for free - -and be entered to win a 42" plasma tv or your very own
Sony(tm)PSP.  Click here to play: http://sourceforge.net/geronimo.php
--
squirrelmail-users mailing list
Posting Guidelines: http://www.squirrelmail.org/wiki/MailingListPostingGuidelines
List Address: [hidden email]
List Archives: http://news.gmane.org/thread.php?group=gmane.mail.squirrelmail.user
List Archives:  http://sourceforge.net/mailarchive/forum.php?forum_id=2995
List Info: https://lists.sourceforge.net/lists/listinfo/squirrelmail-users