[SM-USERS] Cpanel password change and compability pluggins

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[SM-USERS] Cpanel password change and compability pluggins

Tawia Pachuau
My hosting does not provide me a shell access but somehow managed to install squirellmail in my webspace (by manually editting the config file manually) and it is working fine now.

now i wanted to install the cpanel password changer pluggin but that require the compability pluggin to be installed in my squirrelmail. I'm confused what files should be changed for this compability pluggin to be installed.

In the install manual it saya i have to run
$ patch -p0 < compatibility/patches/compatibility_patch-1.4.4.diff

the contents of compatibility_patch-1.4.4.diff is

--- ../include/validate.php.orig    2005-05-05 02:16:13.041876608 -0700
+++ ../include/validate.php    2005-05-05 02:16:10.068328656 -0700
@@ -42,6 +42,7 @@
 require_once(SM_PATH . 'functions/global.php');
 require_once(SM_PATH . 'functions/strings.php');
 require_once(SM_PATH . 'config/config.php');
+include_once(SM_PATH . 'plugins/compatibility/functions.php');
 
 /* set the name of the session cookie */
 if(isset($session_name) && $session_name) {


Where do i put those lines.

Please help me.

Regards
Reply | Threaded
Open this post in threaded view
|

Re: [SM-USERS] Cpanel password change and compability pluggins

Paul Lesniewski


Tawia Pachuau wrote:

> My hosting does not provide me a shell access but somehow managed to
> install squirellmail in my webspace (by manually editting the config
> file manually) and it is working fine now.
>
> now i wanted to install the cpanel password changer pluggin but that
> require the compability pluggin to be installed in my squirrelmail. I'm
> confused what files should be changed for this compability pluggin to be
> installed.
>
> In the install manual it saya i have to run
> $ patch -p0 < compatibility/patches/compatibility_patch-1.4.4.diff
>
> the contents of compatibility_patch-1.4.4.diff is
>
> --- ../include/validate.php.orig    2005-05-05 02:16:13.041876608 -0700
> +++ ../include/validate.php    2005-05-05 02:16:10.068328656 -0700
> @@ -42,6 +42,7 @@
>  require_once(SM_PATH . 'functions/global.php');
>  require_once(SM_PATH . 'functions/strings.php');
>  require_once(SM_PATH . 'config/config.php');
> +include_once(SM_PATH . 'plugins/compatibility/functions.php');
>  
>  /* set the name of the session cookie */
>  if(isset($session_name) && $session_name) {
>
>
> Where do i put those lines.

Just read the patch.  It tells you to edit include/validate.php and look
for the lines shown, adding the one line prefixed with the plus sign.

 -paul


-------------------------------------------------------
SF.Net email is sponsored by:
Tame your development challenges with Apache's Geronimo App Server. Download
it for free - -and be entered to win a 42" plasma tv or your very own
Sony(tm)PSP.  Click here to play: http://sourceforge.net/geronimo.php
--
squirrelmail-users mailing list
Posting Guidelines: http://squirrelmail.org/wiki/wiki.php?MailingListPostingGuidelines
List Address: [hidden email]
List Archives: http://news.gmane.org/thread.php?group=gmane.mail.squirrelmail.user
List Archives:  http://sourceforge.net/mailarchive/forum.php?forum_id=2995
List Info: https://lists.sourceforge.net/lists/listinfo/squirrelmail-users