Message lost when forwarding

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Message lost when forwarding

Ryan Dagey-2
Hello All:

One of our users just brought a strange problem to our attention. When they
click ‘Forward’ on some emails, the entire message is lost. So far, they
have been able to replicate for us on one email, which happens to be from a
German user (we are in the US). Other messages forward just fine, so we’re
thinking perhaps an encoding/charset issue? Our default charset is the
default:
1.  Default Language       : en_US
2.  Default Charset        : iso-8859-1
3.  Enable lossy encoding  : FALSE

Below is the output of our configtest.php for version info.

We are not sure where to look or how to troubleshoot this issue. There is no
error, the compose window after clicking forward just has the user’s
signature block in the message textarea. I checked the permissions of the
message file causing the issue and everything was fine.

Any thoughts on where we should look to help out our user? Thanks for any
help you can provide.

SquirrelMail version:
1.4.22
Config file version:
1.4.0
Config file last modified:
27 March 2015 15:41:21
Checking PHP configuration...
    PHP version 5.5.22-pl0-gentoo OK.
    Running as apache(81) / apache(81)
    display_errors:
    error_reporting: 4177
    variables_order OK: GPCS.
    PHP extensions OK. Dynamic loading is disabled.
    ERROR: You have configured PHP not to allow short tags
(short_open_tag=off). This shouldn't be a problem with SquirrelMail or any
plugin coded coded according to the SquirrelMail Coding Guidelines, but if
you experience problems with PHP code being displayed in some of the pages
and changing setting to "on" solves the problem, please file a bug report
against the failing plugin. The correct contact information is most likely
to be found in the plugin documentation.
Checking paths...
    Data dir OK.
    Attachment dir OK.
    Plugins OK.
    Themes OK.
    Default language OK.
    Base URL detected as: http://webmail.domain.com/src (location base
autodetected)
Checking outgoing mail service....
    SMTP server OK (220 mail.domain.com ESMTP)
Checking IMAP service....
    IMAP server ready (* OK [CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE
THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA IDLE AUTH=PLAIN ACL
ACL2=UNION] Courier-IMAP ready. Copyright 1998-2011 Double Precision, Inc.
See COPYING for distribution information.)
    Capabilities: * CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE
THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA IDLE AUTH=PLAIN ACL
ACL2=UNION
Checking internationalization (i18n) settings...
     gettext - Gettext functions are available. On some systems you must
have appropriate system locales compiled.
     mbstring - Mbstring functions are available.
     recode - Recode functions are unavailable.
     iconv - Iconv functions are available.
     timezone - Webmail users can change their time zone settings.
Checking database functions...
    not using database functionality.
Congratulations, your SquirrelMail setup looks fine to me!

--
Ryan Dagey



------------------------------------------------------------------------------
Dive into the World of Parallel Programming The Go Parallel Website, sponsored
by Intel and developed in partnership with Slashdot Media, is your hub for all
things parallel software development, from weekly thought leadership blogs to
news, videos, case studies, tutorials and more. Take a look and join the
conversation now. http://goparallel.sourceforge.net/
-----
squirrelmail-users mailing list
Posting guidelines: http://squirrelmail.org/postingguidelines
List address: [hidden email]
List archives: http://news.gmane.org/gmane.mail.squirrelmail.user
List info (subscribe/unsubscribe/change options): https://lists.sourceforge.net/lists/listinfo/squirrelmail-users
Reply | Threaded
Open this post in threaded view
|

Re: Message lost when forwarding

Paul Lesniewski
On 3/27/15, [hidden email] <[hidden email]> wrote:

> Hello All:
>
> One of our users just brought a strange problem to our attention. When they
> click ‘Forward’ on some emails, the entire message is lost. So far, they
> have been able to replicate for us on one email, which happens to be from a
> German user (we are in the US). Other messages forward just fine, so we’re
> thinking perhaps an encoding/charset issue? Our default charset is the
> default:
> 1.  Default Language       : en_US
> 2.  Default Charset        : iso-8859-1
> 3.  Enable lossy encoding  : FALSE
>
> Below is the output of our configtest.php for version info.
>
> We are not sure where to look or how to troubleshoot this issue. There is
> no
> error, the compose window after clicking forward just has the user’s
> signature block in the message textarea. I checked the permissions of the
> message file causing the issue and everything was fine.
>
> Any thoughts on where we should look to help out our user? Thanks for any
> help you can provide.
>
> SquirrelMail version:
> 1.4.22
> Config file version:
> 1.4.0
> Config file last modified:
> 27 March 2015 15:41:21
> Checking PHP configuration...
>     PHP version 5.5.22-pl0-gentoo OK.
>     Running as apache(81) / apache(81)
>     display_errors:
>     error_reporting: 4177
>     variables_order OK: GPCS.
>     PHP extensions OK. Dynamic loading is disabled.
>     ERROR: You have configured PHP not to allow short tags
> (short_open_tag=off). This shouldn't be a problem with SquirrelMail or any
> plugin coded coded according to the SquirrelMail Coding Guidelines, but if
> you experience problems with PHP code being displayed in some of the pages
> and changing setting to "on" solves the problem, please file a bug report
> against the failing plugin. The correct contact information is most likely
> to be found in the plugin documentation.
> Checking paths...
>     Data dir OK.
>     Attachment dir OK.
>     Plugins OK.
>     Themes OK.
>     Default language OK.
>     Base URL detected as: http://webmail.domain.com/src (location base
> autodetected)
> Checking outgoing mail service....
>     SMTP server OK (220 mail.domain.com ESMTP)
> Checking IMAP service....
>     IMAP server ready (* OK [CAPABILITY IMAP4rev1 UIDPLUS CHILDREN
> NAMESPACE
> THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA IDLE AUTH=PLAIN ACL
> ACL2=UNION] Courier-IMAP ready. Copyright 1998-2011 Double Precision, Inc.
> See COPYING for distribution information.)
>     Capabilities: * CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE
> THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA IDLE AUTH=PLAIN ACL
> ACL2=UNION
> Checking internationalization (i18n) settings...
>      gettext - Gettext functions are available. On some systems you must
> have appropriate system locales compiled.
>      mbstring - Mbstring functions are available.
>      recode - Recode functions are unavailable.
>      iconv - Iconv functions are available.
>      timezone - Webmail users can change their time zone settings.
> Checking database functions...
>     not using database functionality.
> Congratulations, your SquirrelMail setup looks fine to me!

Please use a snapshot of version 1.4.23 and if that doesn't help,
apply the patch found here:

http://sourceforge.net/p/squirrelmail/bugs/2806/?page=1

Make sure it's version 2 of the patch, not version 1.

--
Paul Lesniewski
SquirrelMail Team
Please support Open Source Software by donating to SquirrelMail!
http://squirrelmail.org/donate_paul_lesniewski.php

------------------------------------------------------------------------------
Dive into the World of Parallel Programming The Go Parallel Website, sponsored
by Intel and developed in partnership with Slashdot Media, is your hub for all
things parallel software development, from weekly thought leadership blogs to
news, videos, case studies, tutorials and more. Take a look and join the
conversation now. http://goparallel.sourceforge.net/
-----
squirrelmail-users mailing list
Posting guidelines: http://squirrelmail.org/postingguidelines
List address: [hidden email]
List archives: http://news.gmane.org/gmane.mail.squirrelmail.user
List info (subscribe/unsubscribe/change options): https://lists.sourceforge.net/lists/listinfo/squirrelmail-users
Reply | Threaded
Open this post in threaded view
|

Re: Message lost when forwarding

Ryan Dagey-2
In reply to this post by Ryan Dagey-2


On March 29, 2015 12:30:58 AM EDT, Paul Lesniewski <[hidden email]> wrote:
>
>Please use a snapshot of version 1.4.23 and if that doesn't help,
>apply the patch found here:
>
>http://sourceforge.net/p/squirrelmail/bugs/2806/?page=1

Thanks, Paul, upgrading to 1.4.23 appears to have taken care of it for us!

--
Ryan Dagey [mobile]

------------------------------------------------------------------------------
Dive into the World of Parallel Programming The Go Parallel Website, sponsored
by Intel and developed in partnership with Slashdot Media, is your hub for all
things parallel software development, from weekly thought leadership blogs to
news, videos, case studies, tutorials and more. Take a look and join the
conversation now. http://goparallel.sourceforge.net/
-----
squirrelmail-users mailing list
Posting guidelines: http://squirrelmail.org/postingguidelines
List address: [hidden email]
List archives: http://news.gmane.org/gmane.mail.squirrelmail.user
List info (subscribe/unsubscribe/change options): https://lists.sourceforge.net/lists/listinfo/squirrelmail-users