Charset/encodn problem when replying emails

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Charset/encodn problem when replying emails

marciano
SM version 1.4.22 
Centos 6.7 
PHP 5.3.3 
Apache 2.2.15
Plugins: 
1. filters
2. delete_move_next
3. message_details
4. newmail
5. translate
6. squirrelspell
7. set_user_data
last versions
Postfix 2.6.6, Dovecot 2.0.9 installes from Webmin CP
Tests from Firefox (Ubuntu, XP), Thundirbird (Ubuntu client), Safari Mac

This is a problem about special chars like accented vowels (Spanish language option selected).
No problem creating email.  Recipient receives it correctly (same in Squirrelmail and Thundirbird).

The problem comes when the recipient answers the sender keeping the original text with those accented vowels or sends a new mail with new ones.
Sender receives correctly the replied (or new) message but when he replies again to the recipient those accented vowels are not interpreted correctly.

Below some screenshots.
Thank you

Sender’s Inbox getting a new email with accented vowels:


Reading incoming email content:
 


Replying email:

------------------------------------------------------------------------------

-----
squirrelmail-i18n mailing list
Posting guidelines: http://squirrelmail.org/postingguidelines
Information about translations: http://squirrelmail.org/wiki/LanguageTranslation
Statistics for translations: http://l10n-stats.squirrelmail.org/
List address: [hidden email]
List archives: http://news.gmane.org/gmane.mail.squirrelmail.internationalization
List info (subscribe/unsubscribe/change options): https://lists.sourceforge.net/lists/listinfo/squirrelmail-i18n
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Charset/encodn problem when replying emails

André Z. D. A.
I think your problem is more appropriate in the Squirrelmail Users mailing list.

Subscribe that list and send the same message there, someone should be able to help you.

Good bye


> SM version 1.4.22
> Centos 6.7
> PHP 5.3.3
> Apache 2.2.15
> Plugins:
> 1. filters
> 2. delete_move_next
> 3. message_details
> 4. newmail
> 5. translate
> 6. squirrelspell
> 7. set_user_data
> last versions
> Postfix 2.6.6, Dovecot 2.0.9 installes from Webmin CP
> Tests from Firefox (Ubuntu, XP), Thundirbird (Ubuntu client), Safari Mac
>
> This is a problem about special chars like accented vowels (Spanish language option selected).
> No problem creating email. Recipient receives it correctly (same in Squirrelmail and Thundirbird).
>
> The problem comes when the recipient answers the sender keeping the original text with those accented vowels or sends a new mail with new ones.
> Sender receives correctly the replied (or new) message but when he replies again to the recipient those accented vowels are not interpreted correctly.
>
> Below some screenshots.
> Thank you
>
> Sender’s Inbox getting a new email with accented vowels:
>
> Reading incoming email content:
>
> Replying email:

------------------------------------------------------------------------------
-----
squirrelmail-i18n mailing list
Posting guidelines: http://squirrelmail.org/postingguidelines
Information about translations: http://squirrelmail.org/wiki/LanguageTranslation
Statistics for translations: http://l10n-stats.squirrelmail.org/
List address: [hidden email]
List archives: http://news.gmane.org/gmane.mail.squirrelmail.internationalization
List info (subscribe/unsubscribe/change options): https://lists.sourceforge.net/lists/listinfo/squirrelmail-i18n
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Charset/encodn problem when replying emails

Paul Lesniewski
In reply to this post by marciano
On 10/25/15, Daniel Stonek <[hidden email]> wrote:

> SM version 1.4.22
> Centos 6.7
> PHP 5.3.3
> Apache 2.2.15
> Plugins:
> 1. filters
> 2. delete_move_next
> 3. message_details
> 4. newmail
> 5. translate
> 6. squirrelspell
> 7. set_user_data
> last versions
> Postfix 2.6.6, Dovecot 2.0.9 installes from Webmin CP
> Tests from Firefox (Ubuntu, XP), Thundirbird (Ubuntu client), Safari Mac
>
> This is a problem about special chars like accented vowels (Spanish language
> option selected).
> No problem creating email.  Recipient receives it correctly (same in
> Squirrelmail and Thundirbird).
>
> The problem comes when the recipient answers the sender keeping the original
> text with those accented vowels or sends a new mail with new ones.
> Sender receives correctly the replied (or new) message but when he replies
> again to the recipient those accented vowels are not interpreted correctly.

Sorry, must have missed this.  Please try the patch found here:
http://sourceforge.net/p/squirrelmail/bugs/2806

--
Paul Lesniewski
SquirrelMail Team
Please support Open Source Software by donating to SquirrelMail!
http://squirrelmail.org/donate_paul_lesniewski.php

------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=267308311&iu=/4140
-----
squirrelmail-i18n mailing list
Posting guidelines: http://squirrelmail.org/postingguidelines
Information about translations: http://squirrelmail.org/wiki/LanguageTranslation
Statistics for translations: http://l10n-stats.squirrelmail.org/
List address: [hidden email]
List archives: http://news.gmane.org/gmane.mail.squirrelmail.internationalization
List info (subscribe/unsubscribe/change options): https://lists.sourceforge.net/lists/listinfo/squirrelmail-i18n
Loading...